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How to use this workbook 

The instructions in this workbook have been written for Excel for Office 365 for a Windows 10 
PC. If you use a different version of Excel, for example Excel for the Web, Excel for Office 365 
for Mac, or an older version of Excel, you may have to follow different steps. Please email 
MOT@beds.ac.uk if you need help with your version of Excel. 

The first chapter, The Analysis ToolPak, contains instructions on loading the Analysis ToolPak. 
Once you have done that, you can go through the chapters in any order. If you would like to 
complete the exercises, you will need the exercise file associated with this workbook. You can go 
to https://lrweb.beds.ac.uk/studyhub-library/workbooks and download it from the page. 

If you need this workbook in an alternative format, for example as a Word document, please 
email MOT@beds.ac.uk 

Downloading the exercise files and other workbooks 

You can download the exercise files for this workbook, and all other workbooks from: 
https://lrweb.beds.ac.uk/studyhub-library/workbooks. 

Self-help guides 

You can find more Microsoft Office resources, including one-page self-help guides and video 
guides to performing specific tasks in Word, Excel, and PowerPoint at: 
https://lrweb.beds.ac.uk/computerskills.  

Study Hub self-help resources, including our self-help guides, can be downloaded from: 
https://lrweb.beds.ac.uk/a-z. 

About the Microsoft Office Training team 

Our aim is to support you in your use of Microsoft Office applications whilst studying at the 
University of Bedfordshire. Our Microsoft Office training workshops are designed to equip you 
with the necessary skills required to complete your assignments and dissertation. Our workshops 
range from fundamentals, suitable for complete beginners, to workshops that develop existing 
skills and cover more advanced features. In addition to improving academic performance at 
university, good Microsoft Office skills will also help with your employability. 

Workshops can be arranged for 4 or more students. If you would like to arrange a workshop for 
your group, contact the Microsoft Office Training team on MOT@beds.ac.uk  
If you have an individual training need, please contact us to discuss your requirements. 

Contact us 

Microsoft Office Training team 

01582 489258 
MOT@beds.ac.uk 
  

mailto:MOT@beds.ac.uk
https://lrweb.beds.ac.uk/studyhub-library/workbooks/
mailto:MOT@beds.ac.uk
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mailto:MOT@beds.ac.uk
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The Analysis ToolPak 

The Analysis ToolPak is an Excel add-in program. It includes the following analysis tools:  

Anova: Single Factor 

Anova: Two-Factor with Replication 

Anova: Two-Factor Without Replication 

Correlation 

Covariance 

Descriptive Statistics 

Exponential Smoothing 

F-Test Two-Sample for Variances 

Fourier Analysis 

Histogram 

Moving Average 

Random Number Generation 

Rank and Percentile 

Regression 

Sampling 

t-test: Paired Two Sample for Means 

t-test: 2-Sample Assuming Equal Variances 

t-test: 2-Sample Assuming Unequal 
Variances 

z-test: Two Sample for Means  

You will need to load the Analysis ToolPak into Excel. If you load it onto your own personal 
computer, the Analysis ToolPak will always be available, but if using a computer in the Library, 
you will need to load the ToolPak each time you wish to use it. Once loaded, the analysis tools 
are available from the Data ribbon. 

Load the Analysis ToolPak 

1. Click the File tab, then click Options at the bottom of the left-hand menu. This displays the 
Excel Options dialog box. 
 

Note: you may have to click More… at the bottom of the left-hand menu to see Options.   

2. Click Add-ins in the left-hand menu, then choose Excel Add-ins in the Manage: box and 
click Go…. 

 

3. In the Add-ins dialog box, tick Analysis ToolPak and click OK. 

Note: if you are working on a Mac, click the Tools menu, then click Excel Add-ins at the bottom 
of the list. In the Add-ins available dialog box, tick Analysis ToolPak and click OK.  
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Descriptive statistics 

The Descriptive Statistics tool generates information about the central tendency and variability of 
your data. You can choose to display the descriptive statistics report alongside the data or in a 
new worksheet or workbook. 

In the following example you will use the Descriptive Statistics tool to display summary statistics 
for the body measurements of a sample of 40 male patients. The summary statistics will be 
placed on a new worksheet. Open the exercise file Use Excel to analyse data.xlsx and click the 
Descriptive Statistics worksheet tab to work through this example. 

1. Click the Data tab, then click Data Analysis located in the Analysis group. 
This will display the Data Analysis dialog box. 

2. Click Descriptive Statistics and then click OK.   

 
This will display the Descriptive Statistics dialog box.  

3. Click into the Input Range: box and select cell range A5:P45. The data is grouped by 
columns and there are labels in the first row. 

 
 

Note: The input range should include all the data you want to analyse. The data can be 
grouped by columns or rows. If there are labels included in the selection, the Labels in First 
Row check box should be ticked. 

4. Select New Worksheet Ply: then click into the box on the right and enter ‘Body 
measurement results’. 

   (Continued on next page) 
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5. Tick the Summary statistics checkbox and click OK. 

 
The summary statistics will be displayed on a new worksheet named: Body measurement 
results. You will need to widen the columns to see all the data. 

 

Note: If you use an analysis tool more than once in the same workbook, you will notice each tool 
keeps the settings from the previous time of use. When using Descriptive Statistics for the 
second time, you will need to clear the Input Range and New Worksheet Ply: boxes. 

Try it: Descriptive statistics 

Move to the Body Temp worksheet and use the Descriptive Statistics tool to display summary 
statistics for the body temperature and heart rate of 50 patients. Display the output on the current 
worksheet, starting in cell E12. 
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Descriptive statistics: additional options 

The following output options can be added to the summary statistics: 

 

Confidence Level for Mean 
Select this if you want to include a row in the output table for the confidence level of the mean. 
For example, a value of 95 percent calculates the confidence level of the mean at a significance 
of 5 percent. 

Kth Largest 
Select this if you want to include a row in the output table for the kth largest value for each range 
of data. If you enter 1, this row contains the maximum of the data set; if you enter 2 it shows the 
second largest value etc. 

Kth Smallest 
Select this if you want to include a row in the output table for the kth smallest value for each 
range of data. If you enter 1, this row contains the minimum of the data set; if you enter 2 it 
shows the second smallest value etc. 
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Regression analysis tool 

The Regression tool performs linear regression analysis by fitting a line through a set of 
observations using the "least squares" method. You can analyse how a dependent variable is 
affected by the values of independent variables.    

In the following example you will use the regression tool to analyse how systolic blood pressure 
is affected by a patient’s age. Open the exercise file Use Excel to analyse data.xlsx and click 
the Systolic blood pressure worksheet tab to work through this example. 

1. Click the Data tab, then click Data Analysis located in the Analysis group. 
This will display the Data Analysis dialog box. 

2. Click Regression and then click OK.   

 
This will display the Regression dialog box.  

3. Click in the Input Y Range: box and select the cells C1:C16 (Systolic blood pressure (y)). 
Include the heading in your selection. 

4. Click in the Input X Range: box and select the cells B1:B16 (Age (x)). Include the heading in 
your selection. 
 

Note: When you are performing a regression analysis, the order of the variables is very 
important. Make sure your dependent variables are your Y range, and your independent 
variables are your X range. 

5. Tick the Labels checkbox.  
 

Note: You need to do this when you include labels (text headings) in your x and y selections 
(as you did in steps 3 & 4). 

 
 

(Continued on next page) 
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6. Select Output Range: then click into the box to the right and click into cell A20 (or type A20). 
Click OK. 

 

The results will now be displayed, starting in the cell A20. 

 

Note: The following output options are optional: Residuals, Standardized Residuals, Residual 
Plots, Line Fit Plots, Normal Probability Plots. There is a brief description of each option on 
the next page. 

Try it: Regression 

Move to the Birth Weight worksheet and use the Regression tool to analyse how an infant’s 
birth weight is affected by gestation time. Display output on the Birth Weight worksheet,  
starting in cell A14. 
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Regression analysis: additional options 

There are more output options available, including residual plots, line fit plots and normal 
probability plots (as shown below).    

 

Confidence Level 
Select to include an additional level in the summary output table. In the box, enter the confidence 
level you want applied in addition to the default 95 percent level. 

Constant is Zero 
Select this to force the regression line to pass through the origin. 

Residuals 
Select to include residuals in the residuals output table. 

Standardized Residuals 
Select to include standardized residuals in the residuals output table. 

Residual Plots 
Select to generate a chart for each independent variable versus the residual. 

Line Fit Plots 
Select to generate a chart for predicted values versus the observed values. 

Normal Probability Plots 
Select to generate a chart that plots normal probability. 
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Try it: Regression analysis additional options 

Move to the Sales worksheet and use the Regression tool to display all the available output 
options for Residuals and Normal Probability. Display the output on a new worksheet named 
Expenditure Results. You will need to re-position the charts. 
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t-Test: Paired Two Sample for Means 

T-tests are often used to compare the means from two different groups of data. They can help to 
determine if means are significantly different from one another, or if they are relatively the same. 
The following t-Test analysis tools are available: 

t-Test: Paired Two Sample for Means 
t-Test: Two-Sample Assuming Equal Variances  
t-Test: Two-Sample Assuming Unequal Variances 

In the following example you will use a paired test to analyse data showing heart rate before and 
after caffeine. This test is used when there is a natural pairing of observations in the samples, 
such as when a sample group is tested twice (example: before and after an experiment). Open 
the exercise file Use Excel to analyse data.xlsx and click the t-Test Paired worksheet tab to 
work through this example. 

1. Click the Data tab, then click Data Analysis located in the Analysis group. 
This will display the Data Analysis dialog box. 

2. Click t-Test: Paired Two Sample for Means and then click OK.   

 
This will display the t-Test: Paired Two Sample for Means dialog box.  

3. Click into the Variable 1 Range: box and select cells B1:B4. Include the heading in your 
selection. 

4. Click into the Variable 2 Range: box and select cells C1:C4. Include the heading in your 
selection. 

5. Tick the Labels checkbox.  
 

Note: You need to do this when you include labels (text headings) in your selections (as you 
did in steps 3 & 4). 

   (Continued on next page) 
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6. Select Output Range: then click into the box to the right, and click into cell F1 (or type F1).  
Click OK. 

 
The results will now be displayed, starting in the cell F1. You will need to widen the columns 
to display all the data. 

 

Try it: t-Test Paired Two Sample for Means 

Move to the t-Test Paired (2) worksheet and use the t-Test: Paired Two Sample for Means to 
analyse the runners’ data. Display the output in a new workbook. You do not have to save the 
new workbook. 
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t-Test: Two-Sample Assuming Equal Variances 

In the following example you will use the t-Test: Two-Sample Assuming Equal Variances tool 
to analyse data showing 16 patients. Eight patients have healthy eyes and 8 are affected by 
glaucoma. Open the exercise file Use Excel to analyse data.xlsx and click the t-Test Equal 
Variances worksheet tab to work through this example. 

1. Click the Data tab, then click Data Analysis located in the Analysis group. 
This will display the Data Analysis dialog box. 

2. Click t-Test: Two-Sample Assuming Equal Variances and then click OK.   

 
This will display the t-Test: Two-Sample Assuming Equal Variances dialog box.  

3. Click into the Variable 1 Range: box and select cells A3:I3 (patients with Glaucomatous 
eyes). Include the row heading in your selection. 

4. Click into the Variable 2 Range: box and select cells A6:I6 (patients with healthy eyes). 
Include the row heading in your selection. 

5. Tick the Labels checkbox.  
 

Note: You need to do this when you include labels (text headings) in your selections (as you 
did in steps 3 & 4). 

  

6. Select Output Range: then click into the box to the right and click into cell K1 (or type K1). 
Click OK. 

 

(Continued on next page) 
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The results will now be displayed, starting in the cell K1. You will need to widen the columns 
to display all the data. 

 

Try it: t-Test: Two-Sample Assuming Equal Variances 

Move to the t-Test Equal Variances (2) worksheet and use the t-Test: Two Sample Assuming 
Equal Variances to analyse the treatments data. Display the output in the current worksheet, 
starting in cell F1. 
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ANOVA: Single Factor 

The ANOVA analysis tools offer the following variance analyses. The tool you use depends on 
the number of factors and the number of samples you have from the populations you want to 
test. 

ANOVA: Single Factor: Single variance analysis 
ANOVA: Two-Factor with Replication: Variance analysis that includes more than one sample 
of data for each group 
ANOVA: Two-Factor without Replication: Variance analysis that does not include more than 
one sample of data for each group  

In the following example you will use the Anova Single Factor tool to analyse 3 samples of cell 
data. Open the exercise file Use Excel to analyse data.xlsx and click the Anova worksheet tab 
to work through this example. 

1. Click the Data tab, then click Data Analysis located in the Analysis group. 
This will display the Data Analysis dialog box. 

2. Click Anova: Single Factor and then click OK.   

 
This will display the Anova: Single Factor dialog box.  

3. Click into the Input Range: box and select cells A1:C9 (column labels are included). Click 
Labels in First Row. 
 

Note: The input range must consist of two or more adjacent ranges of data arranged in 
columns or rows. In this example the data is arranged in Columns. 

  

 

(Continued on next page) 
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4. Select Output Range: then click into the box to the right, and click into cell A13 (or type 
A13). Click OK. 

 
The results will now be displayed, starting in the cell A13. 

 

Try it: Anova: Two-Factor  

Move to the Anova Two-Factor worksheet. Use the Anova: Two-Factor Without Replication 
tool on the data in cells A2:E5 to test which formulations (blends) of fertilizer are most effective. 
Display the output in the current worksheet, starting in cell A20. 
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Use the Anova: Two-Factor With Replication tool on the data in cells G2:K17 to test which 
formulations (blends) of fertiliser are most effective. Note that there are 5 samples (rows) for 
each crop. Display the output in the current worksheet, starting in cell I20. 
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Creating a histogram and frequency table 

A histogram is a graphical representation of the distribution of data. It is like a column chart, but 
each column represents a range of data. 

In the following example you will create a histogram and frequency distribution table for data 
showing the test results of 60 students. Open the exercise file Use Excel to analyse data.xlsx 
and click the Histogram worksheet tab to work through this example. 

1. Click the Data tab, then click Data Analysis located in the Analysis group. 
This will display the Data Analysis dialog box. 

2. Click Histogram and then click OK.   

 
This will display the Histogram dialog box.  

3. Click into the Input Range: box and select cells A2:J7. Do not include the heading. 

4. Click into the Bin Range: box and select cells A10:A16. These are the class intervals.

  

5. Select Output Range: then click into the box to the right, and click into cell C10 (or type 
C10). Cell C10 will be the upper left cell of the histogram and frequency table. 

6. Tick the Chart Output checkbox and click OK. 

  
Note: You can also choose to display a Pareto (sorted histogram) and the cumulative 
percentage. 
 
(Continued on next page) 
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The results will now be displayed, starting in the cell C10. The presentation of the histogram 
can be improved.  

 

Try it: Histogram  

Note: If you use an analysis tool more than once in the same workbook, you will notice each tool 
keeps the settings from the previous time of use. When using the Histogram tool for the second 
time, you will need to clear the Input Range, Bin Range and Output Range: boxes. 

Move to the Histogram (2) worksheet and create a histogram and frequency table to show 
newspaper sales. Display the output on the current worksheet. 
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Formatting a histogram 

The appearance of a histogram can be improved by removing the space between the columns 
and changing the horizontal axis labels. 

In the following example you will change the gap width between the columns on the Student test 
results histogram. Remember, always give your charts descriptive chart and axis titles. Open the 
exercise file Use Excel to analyse data.xlsx and click the Format histogram worksheet tab to 
work through this example. 

1. On the Format histogram worksheet, position the mouse pointer over one of the columns in 
the chart (Student test results histogram), then click the right mouse button. A short-cut menu 
will be displayed. 

2. Click Format Data Series....  

 
Alternatively, double-click one of the columns in the chart. 
This opens the Format Data Series pane. 

3. In Series Options, change Gap Width to 0%. You can use the slider or type 0 into the box. 

 
 
(Continued on next page) 
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This removes the gaps from the histogram.  

 

Note: you can change the colour of the columns by clicking Fill & Line (the paint can icon) in the 
Format Data Series pane. You may have to click Fill to open the fill options, and then click the 
paint can icon next to Color to choose a new colour.   

 

Try it: Format your histogram  

Remove the gaps between the columns of the histogram showing newspaper sales (scroll down 
on the same worksheet to find it). 
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Changing horizontal axis labels 

In the following example you will change the horizontal axis labels for a histogram (produced 
using the Excel Analysis Tools). The new labels will show the class intervals more clearly.  

 

Changing the labels on the horizontal axis of a chart can make the chart more meaningful. 

Open the exercise file Use Excel to analyse data.xlsx and click the Format histogram (2) 
worksheet tab to work through this example. 

1. Enter the labels 10-19, 20-29, 30-39, 40-49, 50-59, 60-69, 70-79, 79+ into cell range L1:L8 as 
shown. 

 
This range contains the labels you want displayed on the primary horizontal axis of the 
Student test results chart. 

2. Click the histogram Student test results. The Chart Design and Format tabs appear on the 
Ribbon.  

3. Click the Chart Design tab and click Select Data, located in the Data group.  

 
This displays the Select Data Source dialog box.  
 
(Continued on next page) 
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4. Click Edit located under Horizontal (Category) Axis Labels.  

 
This displays the Axis Labels dialog box. 

5. Select cells L1:L8 and click OK.  

 
The Select Data Source dialog box will be displayed again. Click OK. 

Try it: Format your histogram  

Enter the following labels starting in cell A33: 15-19, 20-24, 25-29, 30-34, 34+ 

Change the horizontal axis labels for the chart titled: Sales of newspapers using the labels 
starting in A33.  
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Further information 

For further information on the Analysis Tools, please refer to the article Use the Analysis ToolPak 
to perform complex data analysis by Microsoft (2020). 
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